Game Panel — Connection Timeout
Resolved
Auto
Affecting: Game Panel · Aug 17, 2026 6:28 PM IST
· Resolved Aug 17, 2026 6:31 PM IST
(3 minutes)
We are investigating reports of connectivity issues affecting Game Panel.
Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.
Timeline
Resolved
Aug 17, 2026 at 6:31 PM IST · Aug 17, 2026
Opened
Aug 17, 2026 at 6:28 PM IST