Game Panel — Connection Timeout
Resolved
Auto
Affecting: Game Panel · Aug 15, 2026 2:31 AM IST
· Resolved Aug 15, 2026 4:18 PM IST
(13.8 hours)
We are investigating reports of connectivity issues affecting Game Panel.
Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.
Timeline
Resolved
Aug 15, 2026 at 4:18 PM IST · Aug 15, 2026
Opened
Aug 15, 2026 at 2:31 AM IST