Dashboard — Connection Timeout
Resolved
Auto
Affecting: Dashboard · Jul 18, 2026 10:11 AM IST
· Resolved Jul 18, 2026 10:20 AM IST
(9 minutes)
We are investigating reports of connectivity issues affecting Dashboard.
Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.
Timeline
Resolved
Jul 18, 2026 at 10:20 AM IST · 3d ago
Opened
Jul 18, 2026 at 10:11 AM IST