← Back to Incidents
Game Panel — Connection Timeout
Resolved Auto
Affecting: Game Panel · Jul 1, 2026 2:33 PM IST · Resolved Jul 1, 2026 3:13 PM IST (40 minutes)

We are investigating reports of connectivity issues affecting Game Panel.

Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.

Timeline
Resolved
Connectivity to Game Panel has been restored and the service is operating normally.

Total impact duration: 39 minutes.

We apologise for the inconvenience and appreciate your patience.
Jul 1, 2026 at 3:13 PM IST · Jul 1, 2026
Opened
Incident reported and investigation started.
Jul 1, 2026 at 2:33 PM IST