← Back to Incidents
Website — Connection Timeout
Resolved Auto
Affecting: Website · Jun 14, 2026 8:14 PM IST · Resolved Jun 14, 2026 8:15 PM IST (30 seconds)

We are investigating reports of connectivity issues affecting Website.

Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.

Timeline
Resolved
Connectivity to Website has been restored and the service is operating normally.

Total impact duration: 30 seconds.

We apologise for the inconvenience and appreciate your patience.
Jun 14, 2026 at 8:15 PM IST · Jun 14, 2026
Opened
Incident reported and investigation started.
Jun 14, 2026 at 8:14 PM IST