USA-B1 — Host Unreachable
Resolved
Auto
Affecting: USA-B1 · Jun 3, 2026 2:20 PM IST
· Resolved Jun 4, 2026 12:46 PM IST
(22.4 hours)
We are investigating reports of connectivity issues affecting USA-B1.
Our engineering team has been engaged and is working to identify the cause. Further updates will be posted as the investigation progresses.
Timeline
Resolved
Jun 4, 2026 at 12:46 PM IST · 1d ago
Opened
Jun 3, 2026 at 2:20 PM IST